SAP GUI for Java is SAP's GUI solution for customers that do not use Microsoft Windows or that do not want to use SAP GUI for Windows for some reason. Officially, it is only supported on the following platforms (I have excluded the various flavours of Windows and several other systems. For a full list, see the official SAP document):

  • Mac OS X 10.4, 10.5
  • SuSE 10.1, SuSE Linux Enterprise Desktop 10
  • RedHat Enterprise Linux 4, 5
  • Fedora 7, 8, 9
  • Open SuSE 10.2, 10.3

What a shame: FreeBSD is not mentioned. The following steps will show you how to install and use SAP GUI for Java under FreeBSD. Why would you want to do that, anyway? One simple, convincing, and perfectly logical reason: Because we can.

The usual disclaimer: Until Tartarus freezes over, don't expect any support from SAP for that.

That being said, the program actually works. I have tested some transactions (see the screenshots later) and encountered no errors. YMMV.

Requirements: You need a working FreeBSD system (I did this with FreeBSD 7.1), the usual X11 ports and a SUN JRE from /usr/ports/java/linux-sun-jre16. I am also assuming that the Linux ABI support is available and works. If you need help with these steps, the appropriate handbook section might help. Grab SAP GUI for Java (choose the Linux version, for example PlatinGUI-Linux-710r7.jar).

Installation: cd to the directory where the installer is located. Use the JRE to start the installation process by executing the following command in a terminal (change the filename if necessary):

/usr/local/linux-sun-jre1.6.0/bin/java -jar PlatinGUI-Linux-710r7.jar

Choose any installation directory and proceed with the install process. When it has finished, check your selected directory for the folder SAPClients.

After the installation: Open the file SAPClients/SAPGUI7.10rev7/bin/guilogon in a text editor of your choice. Change all references of /usr/bin/test to /bin/test. Finally, set the PLATIN_JAVA variable to your JRE. For example, with tcsh you would to the following:

setenv PLATIN\_JAVA /usr/local/linux-sun-jre1.6.0/bin/java

That's it. You can now run SAP GUI for Java and work with your SAP system. If you don't have one, you might want to download a MiniSAP system for Linux or Windows. Trying to install this under FreeBSD is another story...

Finally, some nice screenshots with FreeBSD 7.1, XFCE, and SAP GUI for Java 7.10rev7:

Posted late Thursday evening, February 12th, 2009 Tags: