After updating my system to FreeBSD 7.0, I received the following error from Opera:

Opera encountered a problem during plug-in setup.
Plug-ins will not work properly.
Check your installation.

Could not locate plug-in 'libnpp.so'.
This executable is included in the install package.

This executable is included in the install package.

Could not start plug-in executable 'operapluginwrapper'
/usr/local/share/opera/plugins/operapluginwrapper

Plug-in path
(Path can be modified in Preferences dialog)

/usr/local/share/opera/plugins

Some searching brought me upon a post in the offical Opera forums. For reference purposes, I will archive it here. To solve the problem, follow these steps:

  • Close Opera
  • Use root to edit the file /etc/libmap.conf (create it if it does not exist)
  • Add the following lines:

      [operapluginwrapper]
      libXThrStub.so.6 libXtst.so.6
    

After a restart, Opera should work fine now. Apparently, only the wrong library is used to start the plugin wrapper, the lines above should fix this.

Posted late Wednesday evening, April 16th, 2008 Tags: